You are here

2 Installing or Upgrading

Primary tabs

Content pulled in from wiki page - http://wiki.openindiana.org/oi/2.+Installing+or+Upgrading


[Handbook editor notes]:

  • This page contained only a table of contents for the 2.x subsections along with user comments, which are pasted below.
  • Ideally the master page for this section should be titled Installing OpenIndiana and upgrading should be subtopic.
  • Also, many of the topics in section 2 are advanced. Perhaps they should be placed under an Advanced Installation section.


Content pulled in from user comments

Anonymous Success! I successfully upgraded my snv_134 installation to oi_147.

During the process, I encountered the following problems:

chash errors in Thunderbird and Firefox. After several restarts (and, in the 2nd case, after waiting for some hours) the update succeeded. After the upgrade, OpenIndiana came up with the (default) US keyboard layout. I was unable to change the keyboard layout via the input method switcher applet. However, I was able to temporarily switch to the desired (German) keyboard layout via: setxkbmap de To fix the keyboard settings permanently, I followed the advice at http://blogs.sun.com/sunwg11nprg/en_US/entry/keyboard_layout_configuration_using_hal (as posted above). My keyboard configuration file for a German standard PS2 keyboard looks like this: <?xml version="1.0" encoding="UTF-8"?> <deviceinfo version="0.2"> <device> <match key="info.capabilities" contains="input.keys"> <merge key="input.x11_options.XkbRules" type="string">base</merge> <merge key="input.x11_options.XkbModel" type="string">pc105</merge> <merge key="input.x11_options.XkbLayout" type="string">de</merge> <merge key="input.x11_options.XkbOptions" type="string">shift:breaks_caps,terminate:ctrl_alt_bksp</merge> </match> </device> </deviceinfo> A big Thank You to the OpenIndiana team for keeping the mainstream distribution of my favourite OS alive!

Peter H. Permalink User icon: Anonymous Sep 19, 2010 Anonymous I have successfully upgraded from SNV_134 to OI_147 & also installed OI_147 on a separate disk. Both of these installations have a bug which I also saw in 145 from Illumos. These installations are on an Asus S96SP laptop (T7200 & 3GB RAM) . Prior to the 145 installation, even up through BFU_138, I was always able to suspend to RAM. With 145 onwards a suspend is immediately followed with a restart. There are no other messages in /var/adm/messages to indicate the failing driver. How can I help to debug this? Permalink User icon: Anonymous Sep 19, 2010 Anonymous Just to be clear: after the suspend there is an immediate resume, not a reboot. Permalink User icon: trisk Sep 20, 2010 Albert Lee http://opensolaris.org/jive/message.jspa?messageID=317052 has some tips on debugging suspend/resume. There's also a pci_wakeup_enable flag you may want to try disabling with

echo 'pci_wakeup_enable/W0t0' | pfexec mdb -kw (see also the recent openindiana-discuss thread). Permalink User icon: Anonymous Sep 21, 2010 Anonymous Albert, thank you for your reply. With uadmin 3 20 on OI_147 I now get a line in dmesg between the suspend & resume lines: "usba: [ID 723738 kern.info] /pci@0,0/pci1043,8263@1a,7 (ehci0): Unable to take control from BIOS. Failure is ignored.". Going back to 134 I also note that I see this line there, but an "auto resume" did not occur. mdb says it doesn't know about 'pci_wakeup_enable/W0t0', nor can I find pci_wakeup_enable anywhere in the Illumos source code. Permalink User icon: trisk Sep 22, 2010 Albert Lee Sorry, the right variable name is 'pci_enable_wakeup'.[laptop-discuss] Laptop resumes from sys-suspend immediately is a more recent thread (for snv_145+) that mentions this. Permalink User icon: Anonymous Sep 22, 2010 Anonymous Thanks, Albert, the setting in /etc/system seems to have fixed the problem. Are there any potential issues with this setting? Permalink User icon: trisk Sep 25, 2010 Albert Lee It may affect your ability to resume from a USB keyboard or mouse. Permalink User icon: Anonymous Sep 24, 2010 Anonymous Upgraded from build 111 to 134 and then to oi_147. This worked fine for the global zone. I did have to update my two non-global zones separately, once at build 134 and then again at build 147 by running "zoneadm -z zonename detach" and then zoneadm -z zonename attach -u" as per various archived discussions about upgrading opensolaris non-global zones. No real problems there except that I had to uninstall amp-dev and php-pgsql (not quite sure php-pgsql was really required to be removed, but I did remove it) to make the upgrade from 134 to 147 work in one of the zones. The upgrade troubleshooting script recommended above was of some help there in figuring out what to remove. After the upgrade from 134 to 147 gdm would no longer run in my 2 non-global zones. Long ago I did have to hack it a bit to get it to work on 111, things changed some after build 134 I suppose. My new trick to fix it is to edit /lib/svc/method/svc-dbus and comment out:

  1. cwjordan commented out so gdm will run
  2. if smf_is_nonglobalzone; then
  3. /usr/sbin/svcadm disable -t svc:/system/dbus
  4. echo "dbus-daemon cannot be run in non-global zones"
  5. sleep 5 &
  6. exit $SMF_EXIT_OK
  7. fi This lets dbus start in the non-global zone. I suppose dbus doesn't really work in the non-global zone properly, but gdm seems to run fine. I don't know what the other consequences of making that change are. Permalink User icon: Anonymous Mar 08, 2011 Anonymous Is installing to USB stick supported? If yes, are write cycles to boot partition minimized? Permalink User icon: deanoc Mar 08, 2011 Deano Calver Installing to USB stick is supported BUT no major work has been done to reduce wear. Permalink User icon: Anonymous Jun 06, 2011 Anonymous On a new install how do you login as root? The install Username and Password do not have root permissions Permalink User icon: scarcry Jun 07, 2011 Marco van Lienen you can't login as root since root is not an account but a role. use: sudo su - (enter the password you set for the user you created) to "become" root. Permalink User icon: Anonymous Oct 10, 2011 Anonymous I've tried it in VirtualBox (with Win XP & 7 as Host OS) and it runs so cool! But what's the root password I should use? Permalink User icon: Anonymous Jul 16, 2011 Anonymous Has to be the easiest & fastest Solaris upgrade I've ever had, and problem-free. Terribly, terribly cool. I almost giggled. Permalink User icon: Anonymous Aug 11, 2011 Anonymous when I install oi_148,after selecting keyboard and language there's no desktop appears,but there is nothing wrong to install it in VisualBox and VMware. My graphic card is GeForce 310M Isn't it supported? Permalink User icon: Anonymous Sep 21, 2011 Anonymous I cannot seem to install the live version on my computer. It goes through the install but goes eventually asks for the logon instead of hitting the GUI for the install. I am using an itx Zotac board with an i3 2105 processor using HD 3000 graphics. I have read of others success stories with similar setups.